Pomoc dla świeżaka

Zaczęty przez jordan87, 27 Luty 2013, 21:15:52

« poprzedni - następny »

jordan87

27 Luty 2013, 21:15:52 Ostatnia edycja: 09 Marzec 2016, 21:54:12 by TomTelos
Hej

Od kilku dni jestem właścicielem przerobionego nboxa. Powoli zaczynam ogarniać coraz więcej ale mam problem jeszcze z kilkoma funkcjami. 
Wgrałem aktualnie najnowszą wersje Freeboxa 8.1 z modem.

Mój tuner to 5800sx BSLA z wbudowanym dyskiem 250GB i na tym sofcie w ogóle nie udało mi się go uruchomić tak aby nań nagrywał lub odtwarzał z niego filmy. Na np Enigmie od razu dysk działał. Próbowałem uruchomić Inicjalizacje dysku z menu ale bardzo długo (około 2h) wisi na tym komunikacie i nie widać końca. Próbowałem usuwać partycja z kompa i czystego dysku również nie udało mi się uruchomić. Stworzyłem nawet cztery partycje z użyciem telnetu i fdisk'a ale prawdopodobnie trzeba jeszcze je jakoś zamontować czego mi się nie udało.

Kolejna sprawa, ale tej na żadnym sofcie nie udało mi się dobrze uruchomić. Wyłączenie zamiast standby. Zawiesza mi się na ekranie trwa wyłączanie i tyle. Czy tu trzeba spełnić jakiś warunek aby ta funkcja zadziałała? I czy ze stany Wyłączenia może się wybudzić w celu nagrania audycji z timera?

Zainstalowałem plugin Cool TV Guide ale nie wiem jak wywołać jego menu. Sprawdzałem w pluginach i w standardowym EPG ale nigdzie nie widzę :(

Przepraszam jeśli uraziłem czyjeś uczucia bo uważa że pytam o podstawy podstaw ale poświęciłem temu tunerowi sporo moich godzin w ostatnim tygodniu i powoli zapominam jak się nazywam :P

tux

Opisz dokładnie co i jak robisz z dyskiem.
Podpowiedź → partycjonowanie + formatowanie z telnet → pamiętaj o etykietkach na partycjach.

Tuner nie ma deepstandby. NIE WOLNO UŻYWAĆ TEGO TRYBU. Całe urządzenie jest zaprojektowane do prac ciągłej.

CoolTVGuide należy przpisać pod jakiś klawisz (np. EPG) w konfiguracji pilota w menu.
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

jordan87

27 Luty 2013, 21:59:49 #2 Ostatnia edycja: 30 Kwiecień 2013, 01:02:38 by tux
Co do dysku no to partycjonowanie i formatowanie według FAQ http://nbox.xunil.pl/index.php/FAQ
FAQ ma opis dla pendrive ale zastosowałem go dla dysku.
sda1 512mb ext2 "system1" juz wrzucilem system na probe i udalo mi sie zabootowac
sda2 512mb ext2 "system2" druga partycja na system, na razie czysta
sda3 256mb ext2 "data" myslalem zeby go wykozystac jako swap ale jeszcze nie wiem jak
sda4 ext2 "movie" pozostałe 240GB jako partycja z danymi
O czyms zapomniałem?

tux

sda4 format na ext4 → względy fragmentacji → etykieta \"records\"
sda3 format swap + etykieta \"swap\" lub ext4 i etykieta \"data\"

sda1 i sda2 → jak jeszcze możesz to format na ext3
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

jordan87

27 Luty 2013, 22:38:23 #4 Ostatnia edycja: 30 Kwiecień 2013, 01:03:13 by tux
Według twoich zaleceń

Device Boot      Start         End      Blocks  Id System
/dev/sda1               1          63      506016  83 Linux
/dev/sda2              64         126      506047+ 83 Linux
/dev/sda3             127         158      257040  83 Linux
/dev/sda4             159       30401   242926897+ 83 Linux

Tylko nie jestem pewien czy właściwej komendy użyłem do formatowania swapa
mkswap -L"swap" /dev/sda3

Każda inicjalizacja dysku z pozycji menu rozwali tablice partycji?

edit.

Widze że dysk już nagrywa
Głównym problemem była nazwa czy brak ext4?

tux

  • mkswap ok
  • tak każda inicjalizacja wywali tablicę partycji → docelowo nie będzie w ogóle opcji w menu
  • głównym powodem etykieta records. ext4 dlatego że ten system mam zaimplementowaną opcję zapobiegania fragmentacji a nBox ładnie supportuje ext4
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

jordan87

27 Luty 2013, 23:19:28 #6 Ostatnia edycja: 27 Luty 2013, 23:21:32 by jordan87
Istnieje możliwość dodania ręcznie wsparcia chipsetów wifi dla innych kart? Mam w domu karty na chipsetach  

BCM43236

RTL8191SU

ZyDAS 1211B RF Chip Airoha AL2330S wynalazek sagema dodawany do liveboxa



Myślałem o głębokim standby bo mierzyłem pobór prądu i między normalnym
działaniem a czuwaniem prawie nie ma różnicy 25-20W, dosyć sporo 20W jak
 na czuwanie.



Dzięki za pomoc z dyskiem i EPG

tux

27 Luty 2013, 23:36:44 #7 Ostatnia edycja: 27 Luty 2013, 23:37:40 by tux
Po uśpieniu dysku 18W na standby 12W.
Tuner można wykorzystywać do różnych celów jak śpi. U mnie służ jako HDD dla drugiego po NFS.

Co do modułów jądra → w późniejszym czasie tak. Nie sprecyzuję jednak pojęcia \"w późniejszym czasie\" na chwilę obecną.
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

jordan87

Pobór mocy jaki podajesz to katalogowy? Bo ja mam watomierz i w standby po uśpieniu dysku mam 20W

tux

Czy Twój watomierz bierze pod uwagę współczynnik przesunięcia konta oraz rozróżnia moc czynną i bierną?
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

franco78

28 Luty 2013, 10:01:53 #10 Ostatnia edycja: 30 Kwiecień 2013, 01:04:48 by tux
 Witam:)
Ja również jestem świeżakiem w temacie nBoxa i Enigmy,
Jak kolega @jordan87 staram się opanować temat i jakoś powoli idzie. Dużo czasu spędzam na forach i dużo czytam. Są już pierwsze efekty;)
Do rzeczy:
nBox z dyskiem, w Nand Enigma 2 - takiego dostałem po przeróbce. Teraz testuje mod tuxa.
Zainstalowałem go przez HDCLone na penie 8G , 3 partycje.
Soft testuje kilka dni. Aktualny i główny problem to "Nie znaleziono HDD lub dysk nie jest zainicjowany" podczas próby nagrywania.
Posiłkowałem się już info z tego tematu, ale bez efektów:(
Dane w Telnet po komendzie fdisk -l
Disk /dev/sda: 250GB
/dev/sda1

Disk /dev/sdb: ok 8GB
/dev/adb1
/dev/adb2
/dev/adb3

Szczegóły w załączniku.
Proszę o pomoc co i jak i gdzie, aby używać dysk.

CZy po tej operacji na sofcie z Nand dysk nadal będzie wykrywany i nadal mogę nagrywać. Bo to działa dobrze na tym sofcie z Nand.
Dziękuję i pozdrawiam,

tux

28 Luty 2013, 11:00:08 #11 Ostatnia edycja: 30 Kwiecień 2013, 01:05:04 by tux
Pena masz do przepartycjonowania → wyraźnie jest napisane dlaczego
Co do "Nie znaleziono HDD lub dysk nie jest zainicjowany"→ chyba posypie się BAN → nawet sekcji ogłoszenia nie przeczytałeś → nie możemy w kółko i do znudzenia pisać o tym samym czyli:
"Nie znaleziono HDD lub dysk nie jest zainicjowany"
Jak ktoś ma problem z opanowaniem czytania to przykro nam. Nawet początkujący musi mieć jakąś wiedzę.

Poza tym, skoro uzyłeś HDCLONE to podejrzewam (mogę się mylić), iż nie wiesz nic lub prawie nic o linuxie. Nie wyobrażam sobie abyś używał tuner z linuxem nie mając podstaw.
Soft wgrywa się nie przez HDCLONE a do nand odpowiednimi plikami lub wypakowuje archiwum na pendrivie do rootfs.
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

jordan87

28 Luty 2013, 11:16:38 #12 Ostatnia edycja: 30 Kwiecień 2013, 01:05:37 by tux
 Co do watomierza to mam dwa. W żadnym nie znalazłem konkretnej informacji od producenta. Jestem jednak skłonny przyjąć że jest to moc czynna z której to rozliczamy się z dostawcą i za nią płacimy.

W obronie franco78 dodam że trudno trafić na ten temat http://forum.xunil.pl/discussion/81/najcześciej-zadawane-pytania

Nie spodziewał bym się takich informacji w dziale "Ogłoszenia"

Co do znajomości linuxa, nie każdy się z nią rodzi. Zresztą tuner można raz skonfigurować i później nie ingerować praktycznie w ogóle.

tux, nie bądź zły na nas

franco78

@tux
czytam sporo, uwierz.
aktualnie mam już soft na penie wypakowane archiwum na pendrivie do rootfs wg. Twojego poradnika.
Szukam więc odpowiedzi w ogłoszeniach.
Dzięki

franco78

28 Luty 2013, 11:21:16 #14 Ostatnia edycja: 30 Kwiecień 2013, 01:06:02 by tux
Prawdopodobnie nie masz nadanej etykietki "records" dla partycji dysku.
Zakładając, iż /dev/sda1 to ten dysk i partycja, które mają być zamontowane do /hdd należy w telnet wpisać:
tune2fs -L "records" /dev/sda1

Po tej operacji w telnecie i restarcie GUI już powinno być wszystko ok?