OpenVPN

Zaczęty przez Dbcooper, 08 Maj 2013, 15:53:05

« poprzedni - następny »

slimaktlen

Cytat: tux w 18 Listopad 2013, 00:08:58
Cytujsprawdzić wykonywalność na wszystkich plikach-chmod755


Mam nadzieje, że kolega nie każe nadać 755 na wszystkie pliki a jedynie te co mają być wykonywalne :)

na moją modłę to 3 ,binarka openvpn,rcS.users,vpn.sh ;)

rekin28

19 Listopad 2013, 19:55:11 #31 Ostatnia edycja: 19 Listopad 2013, 19:59:07 by rekin28
Witam,


mam pytanie jak zrobić żeby połączenie openvpn po rozłączeniu próbowało połączyć się automatycznie, gdyż mam problem gdy dekoder rozłączy się z internetem i połączy ponownie nie łączy się poprzez vpn muszę zrobić restart dekodera.

zember

12 Styczeń 2014, 17:24:17 #32 Ostatnia edycja: 12 Styczeń 2014, 18:04:25 by zember
Witam,

jakis czas temu zainstalowałem sobie openvpn z jakiejs paczuszki w wersji 2.1

nbox:/etc/init.d# /sbin/openvpn --version
OpenVPN 2.1.4 sh4-linux-gnu [SSL] [LZO2] [EPOLL] built on Nov 11 2010
Originally developed by James Yonan
Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@openvpn.net>


działa to bardzo dobrze na configu :
client
remote          x.x.x.x 500
dev             tun
proto           udp
status          current_status
resolv-retry    infinite
ns-cert-type    server
topology        subnet
verb            3

cipher          AES-128-CBC


ca              /etc/openvpn/ca.crt
cert            /etc/openvpn/client.crt
key             /etc/openvpn/client.key
tls-auth        /etc/openvpn/ta.key 1

nobind
persist-key
persist-tun
comp-lzo


gdy zainstalowałem openvpn z opkg w wersji 2.3.2

# /usr/sbin/openvpn --version
OpenVPN 2.3.2 sh4-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [eurephia] [MH] [IPv6] built on Nov 16 2013
Originally developed by James Yonan
Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@openvpn.net>
Compile time defines: enable_crypto=yes enable_debug=no enable_def_auth=yes enable_dlopen=unknown enable_dlopen_self=unknown enable_dlopen_self_static=unknown enable_eurephia=yes enable_fast_install=yes enable_fragment=yes enable_http_proxy=yes enable_iproute2=no enable_libtool_lock=yes enable_lzo=yes enable_lzo_stub=no enable_management=yes enable_multi=yes enable_multihome=yes enable_pam_dlopen=no enable_password_save=no enable_pedantic=no enable_pf=yes enable_pkcs11=no enable_plugin_auth_pam=no enable_plugin_down_root=yes enable_plugins=yes enable_port_share=yes enable_selinux=no enable_server=yes enable_shared=no enable_shared_with_static_runtimes=no enable_small=no enable_socks=yes enable_ssl=yes enable_static=yes enable_strict=no enable_strict_options=no enable_systemd=no enable_win32_dll=yes enable_x509_alt_username=no with_crypto_library=openssl with_gnu_ld=no with_mem_check=no with_plugindir='$(libdir)/openvpn/plugins' with_sysroot=no


i próbuje uruchomić na tym configu oczywiście wcześniej dodaje tun itd.. tak jak poprzednio

otrzymuje następujący komunikat:

/usr/sbin/openvpn --config /etc/openvpn/client.conf
Sun Jan 12 17:18:53 2014 OpenVPN 2.3.2 sh4-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [eurephia] [MH] [IPv6] built on Nov 16 2013
Sun Jan 12 17:18:53 2014 Control Channel Authentication: using '/etc/openvpn/ta.key' as a OpenVPN static key file
Sun Jan 12 17:18:53 2014 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sun Jan 12 17:18:53 2014 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sun Jan 12 17:18:53 2014 Socket Buffers: R=[105472->131072] S=[105472->131072]
Sun Jan 12 17:18:53 2014 UDPv4 link local: [undef]
Sun Jan 12 17:18:53 2014 UDPv4 link remote: [AF_INET]x.x.x.x:500
Sun Jan 12 17:18:54 2014 TLS: Initial packet from [AF_INET]x.x.x.x:500, sid=d4cc588f 3796ceaf
Segmentation fault


i tyle, szukałem rozwiązania tego problemu w necie ale niesety.

Ma ktoś jakieś pomysły?

EDIT:
Może problem jest w tym że w openvpn udostępnionym w repo wyłączony jest pkcs11 albo/i x509?

I w wersji 2.3.2 jest [LZO] zamiast [LZO2] - może to jest powód?

wersja serwera:
/usr/sbin/openvpn --version
OpenVPN 2.2.2 mips-openwrt-linux [SSL] [LZO2] [EPOLL] built on Jul  9 2013
Originally developed by James Yonan
Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@openvpn.net>

slimaktlen

wg mnie jest błąd binarki waży 407mb a jak podmienie na swoją 1700mb to działa

trax

Hej
Czy próbował ktoś połączyć sie OpenVPN do VPN'a jak idostępny w FritzBox 7270?
Bo teoetyczie jest to chyba możliwe

osiemk

26 Luty 2014, 17:29:44 #35 Ostatnia edycja: 26 Luty 2014, 17:50:51 by osiemk
Musi być openvpn we fritzu to wtedy będzie działać - nie znam fritz`a i nie wiem czy jest możliwość w nim zainstalowania openvpn.

K.

PS:
http://www.64k-tec.de/2010/02/fritzbox-tuning-part-2-access-your-home-network-with-openvpn/

osiemk

Binarka pobrana przez opkg działa......ale z małym ale - tylko i wyłącznie na kluczu STATYCZNYM minimalna wersja konfiguracji.
Bardziej rozbudowanej nie próbowałem.
Na pełnych kluczach niestety występuje segmentation fault w momencie weryfikacji kluczy - jako serwer i jako klient.

Pozdrawiam
Krzysztof.

voyteckst

Własnie sprawdziłem na najnowszej wersji GOS i segmentation fault (konfiguracja jako serwer) jest przy próbie połączenia i uwierzytelnienia certyfikatem (zaraz po otrzymaniu przez serwer początkowego pakietu TLS). Wygląda to chyba na jakiś problem z openssl.
Jako tymczasowe rozwiązanie podmieniłem samą binarkę na wersję z H3 - co prawda stara jak świat (2.1_rc19), ale działa jak trzeba.

osiemk

Działa tylko z kluczem statycznym - jako klient i jako serwer.
Przy certyfikatach segmentation fsult jako serwer i klient.
Prawdopodobnie coś w opcjach kompilacji jest do d... lub specjalnie "wersja okrojona" jest bardzo duża różnica w rozmiarze binarki.
Jeżeli jest ktoś zainteresowany mogę wysłać działające konfigi dla static keys.

ipro

Cytat: osiemk w 10 Marzec 2014, 21:12:46
Działa tylko z kluczem statycznym - jako klient i jako serwer.


Sprawdź proszę jeśli możesz, jak zachowuje się binarka z załącznika.

voyteckst

11 Marzec 2014, 06:26:21 #40 Ostatnia edycja: 11 Marzec 2014, 16:43:24 by voyteckst
Cytat: ipro w 11 Marzec 2014, 01:23:59
Sprawdź proszę jeśli możesz, jak zachowuje się binarka z załącznika.

Działa poprawnie, dzięki!

@tux - podmienisz w paczce w repozytorium?

tux

Dodane. Prosze odinstalować paczkę i zainstalować ponownie.
Graterlia OS
VU+ Duo2 (użytkowo), Zgemma i55 (devel)

voyteckst

Cytat: tux w 11 Marzec 2014, 23:05:06
Dodane. Prosze odinstalować paczkę i zainstalować ponownie.

Działa poprawnie. Dzięki!

osiemk

16 Marzec 2014, 20:33:43 #43 Ostatnia edycja: 16 Marzec 2014, 20:36:36 by osiemk
Teraz działa poprawnie z certyfikatami - u mnie jako serwer.
Wielkie podziękowania za poprawkę!
Pozdrawiam
K.

PS.
Dobrze byłoby aby skrypt openvpn.sh w init.d  startował plik client.conf lub server.conf w zależności od skonfigurowania.

mazi

27 Kwiecień 2014, 22:11:56 #44 Ostatnia edycja: 27 Kwiecień 2014, 22:15:24 by mazi
Witam

Zainstalowałem OpenVPN przez opkg wrzuciłem ustawienia jako klient, certyfikaty klucze i otrzymuje coś takiego:

# ./rcS.users.sh
insmod: can't insert '/lib/modules/tun.ko': File exists
sh: off: unknown operand
Start OpenVPN

nie wstaje TUN i openvpn, na pc i telefonie z andkiem wszystko śmiga i trochę się pogubiłem

podpowiecie co moge z tym zrobić??