YouTube

Zaczęty przez TomTelos, 28 Listopad 2015, 12:04:12

« poprzedni - następny »

tux

libidn2.so.0: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu
Failed to load module: /usr/lib/gio/modules/libgiognutls.so

Tylko, że jest to dziwne....ponieważ....
Plik libgiognutls.so znajduje się w pakiecie glib-networking. W pliku control tego pakietu mamy zależność dla gnutls-libs (>= 3.6.1)

Package: glib-networking
Version: 2.54.1
Section: Libraries
Priority: optional
Maintainer: Graterlia OS <graterlia@xunil.pl>
License: LGPLv2
Architecture: mips32el
Depends: glibc (>= 2.26), glib2 (>= 2.54.2), gnutls-libs (>= 3.6.1), ca-certificates
Homepage: http://git.gnome.org/browse/glib-networking/
Source: http://ftp.gnome.org/pub/GNOME/sources/glib-networking/2.54/glib-networking-2.54.1.tar.xz
Description: Networking support for GLib
 This package contains modules that extend the networking support in
 GIO. In particular, it contains a libproxy-based GProxyResolver
 implementation and a gnutls-based GTlsConnection implementation.
Natomiast pakiet glib-networking ma w zależności libidn2:
Package: gnutls-libs
Version: 3.6.3
Section: Libraries
Priority: optional
Maintainer: Graterlia OS <graterlia@xunil.pl>
License: LGPLv2.1+
Architecture: mips32el
Depends: glibc (>= 2.28), libgcc (>= 8.2.0), gmp (>= 6.1.2), libstdc++ (>= 8.2.0), libunistring (>= 0.9.10), zlib (>= 1.2.11), nettle (>= 3.4); libidn2 (>= 2.0.5)
Homepage: http://www.gnu.org/software/gnutls/
Source: ftp://ftp.gnutls.org/gcrypt/gnutls/v3.6/gnutls-3.6.3.tar.xz
Description: GnuTLS shared libraries
 GnuTLS shared libraries.
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

lokode

07 Wrzesień 2018, 12:50:22 #46 Ostatnia edycja: 07 Wrzesień 2018, 13:03:59 by lokode
Wszystko wskazuje więc na to, że instalacja gnutls-libs nie pociąga za sobą libidn2

Spróbuj odinstalować gnutls-libs z zależnościami, po czym wykonaj próbę ponownej instalacji. Jestem ciekaw czy libidn2 również się zainstaluje.

lokode

Nie widzę tutaj libidn2:

GraterliaOS:~# opkg depends glib-networking
glib-networking depends on:
        glibc (>= 2.26)
        glib2 (>= 2.54.2)
        gnutls-libs (>= 3.6.1)
        ca-certificates
GraterliaOS:~# opkg depends gnutls-libs
gnutls-libs depends on:
        glibc (>= 2.28)
        libgcc (>= 8.2.0)
        gmp (>= 6.1.2)
        libstdc++ (>= 8.2.0)
        libunistring (>= 0.9.10)
        zlib (>= 1.2.11)
        nettle (>= 3.4)
GraterliaOS:~# opkg depends gnutls
gnutls depends on:
        glibc (>= 2.28)
        gnutls-libs (>= 3.6.3)

tux

Zaczyna być to zagadką...bo na 100% jest w depends ;(
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

lokode

Niestety, dalej już nie pomogę. Przypomnę tylko, że zainstalowałem najnowszy obraz (ZGemma H2.S). Później aktualizacja (sysupdate), przejście na premium + instalacja wtyczki youtube.

Marioo

Witam,świeży system i problem z zainstalowaniem YouTuba.
executing opkginstall enigma2-plugin-youtube
Collected errors:
 * calculate_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-youtube:

 * enigma2-plugin-mediaservice * gnutls *
 * opkg_solver_install: Cannot install package enigma2-plugin-youtube.
Jakby ktoś pomógł to byłoby extra.
Graterlia OS -- Solo SEv.2, ADB5800sx

tux

Myślę, że  większej  pomocy jak strona internetowa  GOS nie trzeba.
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

Marioo

rozumiem ,pakiet premium.
Graterlia OS -- Solo SEv.2, ADB5800sx

tux

Tak dopiszę jako wytłumaczenie...
Nikt nie zmusza do GOS Premium. Wszystkie powody powstania GOS Premium są opisane na WWW i na Forum.
Graterlia OS
Vu+ Uno 4K SE (użytkowo), Vu+ Zero 4K (devel), Zgemma i55 (devel)

ncage

Instalacja YouTube z terminala jest poprawna i wtyczka działa , bo z Os wywala błąd i się nie instaluje tuner VU+ ?
Graterlia OS na Vu+ Solo v2 SE ; Hyperion 6.4 bo nie ma GOS 2 x Xpeed LX1

314TeR

Cytat: ncage w 07 Styczeń 2020, 20:18:29Instalacja YouTube z terminala jest poprawna i wtyczka działa , bo z Os wywala błąd i się nie instaluje tuner VU+ ?

Możesz zamieścić log z błędami?
System: Graterlia OS Tunery: VU+ Solo2

ncage

Graterlia OS na Vu+ Solo v2 SE ; Hyperion 6.4 bo nie ma GOS 2 x Xpeed LX1

314TeR

Na górze masz ścieżkę do loga, profilaktyczie możesz jego treść zamieścić zamiast zdjęcia, ale i tak na 99% ten błąd już został poprawiony w nowym [NDA obliguje ;)], @tux musiałby potwierdzić. Niestety pewne opóźnienia z nowościami [NDA], że jest poślizg... ale dziękujemy z informację.
System: Graterlia OS Tunery: VU+ Solo2

ncage

YouTube działa- bardzo dziękujemy za poprawki  ;D
Graterlia OS na Vu+ Solo v2 SE ; Hyperion 6.4 bo nie ma GOS 2 x Xpeed LX1